Показано с 1 по 6 из 6

Тема: Microsoft Excel

  1. #1
    Радиослушатель
    Регистрация
    25.01.2005
    Возраст
    37
    Сообщений
    34
    Поблагодарили
    1
    Поблагодарил
    0

    Microsoft Excel

    Здрасте подскажите пожалуйста можно ли такое сделать в Microsoft Excel если да то какую функцию использовать
    нужно следуещее
    чтоб при вводе данных в одной ячейке , данные брались с другой ячейки и вставлялись в третюю ячейку
    например
    в ячейку А1 ввожу число 55
    числу 55 соответствует число 66 которое вписано в ячейку А2
    но число с ячейки А2 автоматически вводится в ячейку А3


  2. #2
    Администратор Аватар для R2AR
    Регистрация
    02.04.2002
    Адрес
    Москва, Russia
    Возраст
    46
    Сообщений
    1,256
    Записей в дневнике
    3
    Поблагодарили
    342
    Поблагодарил
    52
    Цитата Сообщение от kulibin 2005
    чтоб при вводе данных в одной ячейке , данные брались с другой ячейки и вставлялись в третью ячейку
    Если А2 - это функция от А1 (например А2=А1+11), то тогда прямо так и уакзывайте
    в ячейке A2 поставьте курсор и напечатайте =A1+11 и нажмите Enter

    Если же зависимость нелинейная, то тогда нужно писать макрос на VBA, где явно прописать массив сопоставления X<->Y и через него работать

    Кроме того можно этот массив написать прямо в листе Excel, а по значению введенному в А1 вычислять порядковый индекс ячейки внутри этого массива и брать значение прямо оттуда. В этом случае нужно использовать встроенную в Excel функцию. Какую точно не помню. Почитайте мануал в Excele там все подробно расписано

  3. #3
    Радиослушатель
    Регистрация
    25.01.2005
    Возраст
    37
    Сообщений
    34
    Поблагодарили
    1
    Поблагодарил
    0
    изминение значение не линейное надо писать массив и брать значение прямо из ячейки но как и какую функцию использовать

  4. #4
    Администратор Аватар для R2AR
    Регистрация
    02.04.2002
    Адрес
    Москва, Russia
    Возраст
    46
    Сообщений
    1,256
    Записей в дневнике
    3
    Поблагодарили
    342
    Поблагодарил
    52
    Цитата Сообщение от kulibin 2005
    изминение значение не линейное надо писать массив и брать значение прямо из ячейки но как и какую функцию использовать
    Внесите массив колонкой в столбце например F , тогда получить значение можно функцией =ИНДЕКС(F1:F5;A2;1), где:

    F1:F5 - диапазон ячеек с таблицей коэффициентов
    A2 - число которое отображает индекс ячейки (ну вроде как взять такой-то коэффициент из таблицы)

    Тогда в А2 вносите цифру 3, то выведится значение из ячейки F3

  5. #5
    Без позывного
    Регистрация
    17.12.2005
    Адрес
    Москва
    Возраст
    75
    Сообщений
    403
    Поблагодарили
    57
    Поблагодарил
    5
    Если имеется массив ячеек, первую колонку которого можно принять за "код", например, фамилии участников, а остальные колонки - какие-то данные, то логичнее всего применить функцию "ВПР".
    Для Вашего случая можно знести массив вводимых значений (например, в ячейки А11:А***), рядом - массив выходных значений (например в ячейки В11:В***) и тогда функция будет выглядеть: "=ВПР(A1;A11:B***;2;ЛОЖЬ)"

  6. #6
    Радиослушатель
    Регистрация
    25.01.2005
    Возраст
    37
    Сообщений
    34
    Поблагодарили
    1
    Поблагодарил
    0
    ну все получилось спасибо будем пробовать фукнцию ВПР

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •  
Похоже, что вы используете блокировщик рекламы :(
Форум QRZ.RU существует только за счет рекламы, поэтому мы были бы Вам благодарны если Вы внесете сайт в список исключений!
как отключить
×
Рейтинг@Mail.ru
eXTReMe Tracker
Яндекс.Метрика